Phn phối thiết bị mạng MikroTik tại Việt Nam
Results 1 to 1 of 1

Thread: Hướng Dẫn Cấu Hnh Dynamic DNS Trn Router Mikrotik

  1. #1
    Junior Member
    Join Date
    Mar 2020
    Posts
    4

    Post Hướng Dẫn Cấu Hnh Dynamic DNS Trn Router Mikrotik

    Trong bi viết ny mnh sẽ đề cập đến việc Cấu Hnh Dynamic DNS Trn Router Mikrotik đối với NO-IP.
    Mặc định, Mikrotik khng trang bị sẵn tnh năng DDNS trn Router của họ. Chnh v vậy chng ta cần đển Script để giải quyết vấn đề đ.

    Qui trnh hoạt động trong thủ thuật ny như sau:
    1. Script thực thi cc lệnh để kiểm tra IP Public trn Router c sự thay đổi so với trước đ khng?
    Nếu c, thực hiện cập nhật IP Public mới ln HOST NO-IP. Nếu khng, khng lm g cả.
    2. Script khng tự khởi chạy, v vậy lập lịch chạy Script với chu kỳ 5 pht/lần.

    Cc bước thực hiện như sau:
    Bước 1: Tạo mới Script . Trn giao diện Winbox, menu tri v truy cập system->script

    Sau đ nhấn vo dấu + để tạo mới Script. Mọi người đặt tn cho Script(ty )v dn tập lệnh vo phần Source. Lệnh trong Script mnh sẽ upload cuối bi.

    Sau khi đặt tn v dn lệnh vo mọi người nhấn "Apply"->"OK"

    Bước 2: Lập lịch chạy Script. Trn giao diện Winbox, menu tri v truy cập system->scheduler

    Sau đ nhấn vo dấu + để tạo mới lịch. Mọi người đặt tn cho lịch(ty ). Interval: l khoảng thời gian lập lại, thời gian giữa 2 lần thực thi.
    On Event: Mọi người gn tn Script muốn chạy ở đy hoặc lệnh "/system script run DDNS"
    hoặc c thể dn cc lệnh vo đy để thực thi lun v khng cần tạo Script trước đ.
    Trong v dụ ny tn Script l "DDNS" v mnh sẽ chỉ gn tn Script ny vo trong mục "On Event"

    Sau khi xong mọi người nhấn "Apply"->"OK"

    Cuối cng l Script. Script được viết lại bởi KTV Cng ty Sao Thin Vương. C thể p dụng trn RouterGateway v Router behind NAT.
    Code:
    #Thong tin tai khoan NO-IP va HOST.
    :local username "no-ip-user"
    :local password "no-ip-pass"
    :local host "no-ip-host"
    #Cac dong ben duoi khong thay doi.
    :global OldIP
    /ip cloud force-update
    :delay 5
    :local NewIP [/ip cloud get public-address]
    :log info "No-IP: NewIP = $NewIP"
    :if ($NewIP != $OldIP) do={
    :log info "No-IP: New IP $NewIP is not equal to Old IP, update needed"
    :set OldIP $NewIP
    :local url "https://dynupdate.no-ip.com/nic/update/?myip=$NewIP&hostname=$host"
    :log info "No-IP: Sending update for $host"
    /tool fetch url=$url user=$username password=$password mode=https keep-result=no
    :log info "No-IP: Host $host updated on No-IP with IP $NewIP"
    } else={
    :log info "No-IP: update not needed "
    }

    Chc mọi người thnh cng!
    Last edited by nghiavv; 03-06-2020 at 10:55 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •