Router MikroTik tch hợp sẵn firewall layer 7, cho php quản trị vin tuy biến để ngăn chặn (lock) cc trang web khng mun muốn người dng truy cập.

Bn dưới l một trong nhiều cch dng firewall layer 7 của MikroTik để ngăn chặn người dng truy cập trang web youtube.

Code:
/ip firewall layer7-protocol
add name=youtube regexp="^.+(youtube).*\$"

/ip firewall mangle
add action=mark-connection chain=prerouting protocol=udp dst-port=53 connection-mark=no-mark layer7-protocol=youtube new-connection-mark=youtube_connpassthrough=yes
add action=mark-packet chain=prerouting connectionmark=youtube_connnew-packet-mark=youtube_packet 

/ip firewall filter
add action=drop chain=forward packet-mark=youtube_packet
add action=drop chain=input packet-mark=youtube_packet
Thực hiện tương tự để ngăn chặn truy cập trang web facebook.