Hướng dẫn ny gip cc bạn cấu hnh FTTH - PPPoE trn thiết bị router Cisco. Ngoi việc cấu hnh PPPoE, hướng dẫn ny cũng gip bạn biết cch public 1 dịch vụ từ mạng LAN ra ngoi Internet.

Để cấu hnh FTTH - PPPoE trn thiết bị router Cisco, chng ta cần chuẩn bị cc thng tin sau:

- Username nh mạng cung cấp, v dụ: ftth_myUsername
- Password nh mạng cung cấp, v dụ: ftth_myPassowrd

Ch , đối với nh mạng FPT, ngoi username, password của PPPoE, nh mạng FPT cn chứng thực thm MAC address của Khch hng. Do đ, sau khi cấu hnh xong, bạn phải điện thoại nhờ FPT cập nhật địa chỉ MAC trn hệ thống của họ.

Cc bước thực hiện:

- Định nghĩa Interface LAN
- Định nghĩa Interface WAN
- Định nghĩa Dialer Interface, dng để kết nối PPPoE đến nh mạng
- Định nghĩa NAT để người dng trong mạng LAN c thể truy cập Internet
- Định nghĩa IP routing
- Định nghĩa static NAT để public dịch vụ Web trong mạng LAN ra ngoi Internet.

Sau đy l cc bước thực hiện tuần tự:

CISCO(config)# interface GigabitEthernet0/0
CISCO(config-if)#description #LAN Interface#
CISCO(config-if)#ip address 192.168.1.1
CISCO(config-if)#no shutdown
CISCO(config-if)#ip nat inside

CISCO(config)# interface GigabitEthernet0/1
CISCO(config-if)#description #WAN Interface#
CISCO(config-if)#no ip address
CISCO(config-if)#pppoe enable group global
CISCO(config-if)#pppoe-client dial-pool-number 1
CISCO(config-if)#no shutdown


CISCO(config)# interface dialer 1
CISCO(config-if)#description #Dialer interface#
CISCO(config-if)#ip mtu 1492
CISCO(config-if)# dialer pool 1
CISCO(config-if)# encapsulation ppp
CISCO(config-if)# ip address negotiated
CISCO(config-if)#ip nat outside
CISCO(config-if)#ppp pap sent-username ftth_myUsername password 0 ftth_myPassword

CISCO(config)#ip nat inside source list 100 interface Dialer1 overload
CISCO(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any
CISCO(config)#ip route 0.0.0.0 0.0.0.0 Dialer 1

CISCO(config)#ip nat inside source static tcp 192.168.1.100 80 interface Dialer 1 80

Bn dưới l cc lệnh dng để troubleshooting cấu hinh PPPoE, NAT v ti liệu tham khảo:

CISCO(config)#show ip interface brief
CISCO(config)#show ip nat translation
CISCO(config)#debug ppp authentication

Ti liệu tham khảo:
- PPPoE configuration.
- Cấu hnh FTTH - PPPoE load balancing v failover trn 2 WAN của 1 router Cisco.
- Xử l trường hợp mạng nội bộ khng truy cập website nội bộ khi NAT với router Cisco.

Cc bạn cần hỗ trợ dịch vụ, thiết bị mạng Cisco, lin hệ với chung ti tại http://switch-router.com/contact/